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This tutorial guide follows on from Part 1 of the introductory tutorial. We recommend starting
with Part 1, though this part is independent of the data and steps from Part 1.
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CHAPTER 1 — THE DODOMA DATA SET

This tutorial uses daily climatic data from Dodoma in Tanzania, from 1935 to 2013. We are
very grateful to the Tanzania Met Authority who have given permission for these data to be
used for training purposes.

> If the diamonds data are still in R-Instat then use File > Close Data File (Fig. 15)

> You will be asked if you are sure. Respond Yes.

Fig. 15. Closing the previous data file To start again
R R-lnstat 0.5.5
‘R R-Instat 0.5.5 File Edit Prepsre Describe Model Ciimatic Procurement OptionsbyContext Tools View Help
File | Edit Prepare Describe Mod: T-EE G-~ IE‘ BEFO®
New Data Frame... Ctrl+N DalaVien
Open From File... Ctrl+O
-l Open From Library...
Open From ODK...

Open From CSPRO...
Import From Databases...
Import and Tidy NetCDF File...

Convert... No Data Loaded
Save... Ctrl+S
Save As >
Export >
Print... Ctrl+P

Print Preview...

Close Data File

No data loaded

1.1 OPENING THE NEW DATA SET

> Use File > Open from Library. Take the option to Load from Instat Collection and then
press Browse.

» Choose Climatic and select the Excel file Climatic_guide_dataset

> This Excel file has multiple sheets. Choose the one called Dodoma, see Fig. 16.
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Fig 16: Opening the Dodoma sheet

Import Dataset n
File: C:/Users/User/Documents/R-Instat/Climatic-guide_datasetsxisx| Browse |
New Data Frame Name: -
Select Sheets:
[ Select A1
[] Datasets A
Import Excel Options [] Bohicon
[] Brazi
Missing Value String: [] Bulawayo

[ First Row is Column Headers -
[] Facex1
i i [] Huda
[ Tiim Traiing White Space ] Kobete
Rows to Skip: [ Katumani e
0 k= Data Frame Preview: Linesto Preview: 10 |5
_ Year Maonth Day Rain Tmax A
[ Maximum Rows To Impott 1 @an 3 00 NA ”
2 1935 Jan 2 6.3 NA N#
3 193 Jan 3 1.8 NA N/
4 1935 Jan 4 0.0 NA N/
5 1935 Jan 5 0.0 NA N/
6 1935 Jan 6 0.0 NA N#
7 1935 Jan 7 0.0 NA Nt v
< >
Refresh Preview

[ Comment:  |Code generated by the dialog. Import Dataset =

Ok Reset Close Help To Script

The preview (Fig. 16) indicates this is ready to import. There are sensible names and the data
starting on January 1°t.

Fig 17: The Dodoma Daily Data

‘R R-Instat 0.5.5
File Edit Prepare Describe Model Climatic Procurement (
~ 4 i —
- ED B v
Data View
Month (c) Day Rain Tmax Tmin "
1 len 1 0.0 NA NA
2 Jan 2 6.3 NA NA
3 Jan 3 18 NA NA
4 Jan 4 0.0 NA NA
5 Jan 5 0.0 NA NA
6 Jan 6 0.0 NA NA
7 Jan 7 0.0 NA NA
8 Jan 8 05 NA NA
9 Jan 9 0.0 NA NA
10 Jan 10 0.0 NA NA
11 Jan 1 0.0 NA NA
12 Jan 12 0.0 NA NA
13 Jan 13 0.0 NA NA
14 Jan 14 0.0 NA NA
15 Jan 15 0.0 NA NA
v
11>6 Déggma £ L a - i< >
Showing 1000 of 28855 rows | Showing 7 of 7 columns
Dodoma

The data are shown in Fig. 17. These are daily data on rainfall, temperatures, and sunshine
hours. There are 28,855 observations.
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1.2 CHECKING THE DATA SET

One difference from the diamonds example in Part 1 is that missing values are immediately
visible in the data.

> Now use Prepare > Check Data > Visualise Data.
> Just press Ok.

This gives a sort of “picture” of the data, see Fig. 18.

Fig: 18 Dodoma Daily Data and Data Visualisation

File Edit | Prepare | Describe Model  Structured Climatic  Procurement  Options by Context  Tools View Help

Data Frame

Check Data Visualise Data
e— Duplicates... Qutput Window
= Column: Calculate  » Compare Columns...
2 hoe R T n Non-numeric Cases... ¢ & @ ¥ & & &
3 1935 Column: Text » Boxplot...
4 1935 Column: Date ’ One Variable Summarise... !
5 1935 Column: Define ’ One Variable Graph...
g 1935 Data Reshape » One Variable Frequencies...
7 :g Keys and Links » Export To OpenRefine...
3 1935 Data Object » Import From OpenRefine...
10 1935 R Objects 4 Jitter...
1935 Jan 1 Prepare to Share (sdc package)..
121935 Jan 12 Anonymise ID Cokume.. 12000
13 1935 Jan 13 LA T ™ A
4 1935 Jan 14 00 NA NA NA - Tyoe
5193 Jan 15 00 NA NA NA g J—
16 1935 Jan 16 00 NA NA NA § numeric
17 1935 Jan 17 00 NA NA NA A
181935 Jan 18 00 NA NA NA
191935 Jan 19 00 NA NA NA
20 1935 Jan 20 00 NA NA NA
21193 Jan 21 00 NA NA NA o
2 1935 Jan 2 00 NA NA NA
2 1935 Jan 23 00 NA NA NA
24 1935 Jan 24 0.0 NA NA NA
Ll " ac . v.. ALA ALA nin b
' 1< >
Showing 1000 of 28855 rows | Showing 7 of 7 columns

Grey is for the missing values. They indicate that the early years did not record the
temperatures, and sunshine recording started later still. The figure also shows there aren’t
many missing values in the temperatures, once recording started, but the sunshine data is
patchy.

» Return to the Prepare > Check Data menu.

The One Variable Summarise and Graph dialogues are repeated here. You used them from
the Describe menu, but they are often also useful at the initial data checking stage.

» As before, with One Variable > Summarise, look at all the variables.
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Fig: 19 Dodoma Data Summary

# Code generated by the dialog, One Vaniable Summarnse

year month day rain
Min. 19835 Length:28855 Min. : 1.0 Min. ). 00
1st Qu.:1954 Class :character 1st Qu.: 8.0 1st Qu.: ). 00
Median :1974 Mode :character Median :16.0 Median : 0.00
Mean 11974 Mean 15.7 Mean 1.57
3rd Qu.:1964 3rd Qu.:23.0 3rd Qu.: 0.00
Max. 12013 Max. 31.0 Max. :119.80
NA's :91
tmax tmin sunh
Min. :15 Min. : 8 Min. 0
1st Qu.:27 1st Qu.:15 lst Qu.: B
Median :29 Median :17 Median :10
Mean :29 Mean +17 Mean 9
3rd Qu.:30 3rd Qu.:18 3rd Qu.:11
Max. 36 Max. 126 Max. 14
NA's Be31 NA's :8703 NA's 18451

This shows there were just 91 days when the rainfall was missing. The visualisation (Fig 18)
before indicated that there are a large number of missing values for the temperatures and
sunshine. The summary confirms this, showing over 8 thousand values missing for
temperature and over 18 thousand missing from the sunshine data.

On a positive note, there were over 20,000 days when the temperatures were measured, and
more than 10,000 with sunshine data. Also notice there were no missing values on the year
or day variables. That’s comforting because, with a daily time series, you can’t proceed if you
don’t know the date!

In hindsight, this presentation also implies that the diamonds data, in tutorial 1, did not have
any missing values, or their presence would have been indicated.

The rainfall data in Fig. 17 are from 1935. The station added temperature records later.

> Use the right-click on the bottom tab and choose View Data (the last option) to view
the whole data.

> Scroll down these data to confirm that the temperatures started from 1958.

This indicates that most of the 8 thousand missing temperature data in Fig. 18 are because of
the later start of measuring these elements.
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CHAPTER 2 — PREPARING THE DATA

Often preparing the data for analysis takes most of the time. We have tried to make the
Prepare menu in R-Instat as simple to use as possible.

Our main work in this tutorial is to examine trends in the annual temperature data. This uses
the Prepare menu because we don’t yet have annual data. These are daily data.

2.1 APPLYING A FILTER

First, filter the data, so it starts in 1958, when the temperatures start. The filter

dialogue is available in Prepare > Data Frame > Filter

However, many common tasks from the Prepare menu are quickly accessible

through a special right-click menu which is shown in Fig. 20.

> Put the cursor in the top row (with the names) and right-click (Fig. 20)

» Choose the Filter dialogue from this menu (Fig 20)

Fig20: The Right-Click Menu Choose a Filter
Year Month (c) Day Rai Citbar
1 1935 Rename Column... =
2 11935 Duplicate Column...
3 1935 Reorder Column(s)... Data Frame:
4 1935 Delete Column dodoma e i
5 ler:
6 :Zi Convert to Factor
7 |o3s Convert to Ordered Factor Fiters
8 |93 Convert to Character no_filter
9 1935 Convert to Logical Add Define New Fitter
10 (1935 Convert to Numeric
1 [1935 Levels/Labels.. Fitter From Factors
12 11935
13 |1935 Freeze to Here e
14 1935 Unfreeze - B
15 11935 Sort... Apply Options
L LT @® Apply As Fiter (O Apply As Subset
17 h93s L
Remove Current Filter
12 haac

Selected Fiter Preview: |[)

Comment: |code generated by the dialog Fitter

Reset Close Help || Lan To Script
> Click on the button in Fig. 20 to Define New Filter.

> In the sub-dialogue, choose the year variable and the condition that is greater than
1957. (Fig 21)

> Add the condition and optionally give the condition a name, we call it from1958. (Fig
21)
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> Press Return and OK.

Fig 21: Define the Filter And then apply it
Define New Filter Filter
Data Frame: Data Frame:
dodoma Filter By:
1957 dodoma ~
Varabl ~ |5'|=i ” e | "| Fiter:
ariables ;

Add Condtion Lamae Fitters Fiter1
year 5 g g /
manth Add - no_fiter
day 4 5 & % A Fiter1 Add Define New Filter
date
month_abbr 1 2 3 = Fiter From Factors

" Clear

doy_366 v 0 () + Edit Fiter
Varable  Condtion Ml Combined with & Apply Options

Edit Condition (® Apply As Fiter () Apply As Subset

Clear Conditions Selected Filter Preview: ({ year > 1957))
Fiiter Preview: |
New Fitter Name |F|her1 " Comment: |code generated by the dialog Fitter

Ok Reset Close Help Lan To Script
Retum Help

> Press the button to Add Condition (Fig. 21) and then press Return.

> On the main filter dialogue (Fig. 21) press OK to apply the filter.

On the left-hand-side the row numbers are now in red — which indicates a filter is in
operation. The data now “start” in row 8402 with the temperature data., i.e. 1st January
1958.

Fig 22: Filtered Data

year month (c) day rain tmax tmin sunh yr_temp (L)

802 1958 Jan 1 l[oo bse 187 ma TRUE
8403 1958 Jan 2 0.0 29.7 18.8 NA TRUE
8404 1958 Jan 3 0.0 297 17.6 NA TRUE
8405 1958 Jan 4 7.1 305 18.8 NA TRUE
406 1958 Jan 5 89 31.2 19.2 NA TRUE
1958 Jan 6 20 311 19.1 NA TRUE

8408 1958 Jan 7 0.0 272 18.1 NA TRUE
8403 1958 Jan 8 0.0 289 18.8 NA TRUE
8410 1958 Jan 9 0.0 30.0 16.7 NA TRUE
8411 1958 Jan 10 0.0 30.1 173 NA TRUE
8412 1958 Jan n 0.0 31.2 19.3 NA TRUE
8413 1958 Jan 12 0.0 31.2 19.1 NA TRUE
8414 1958 Jan 13 0.0 321 183 NA TRUE
8415 1958 Jan 14 0.0 318 18.6 NA TRUE
8416 1958 Jan 15 0.0 329 18.3 NA TRUE
8417 1958 Jan 16 0.0 336 17.8 NA TRUE
8418 1958 Jan 17 0.0 341 19.2 NA TRUE
8415 1958 Jan 18 03 326 18.9 NA TRUE
8420 1958 Jan 19 0.0 333 194 NA TRUE
8421 1958 Jan 20 0.0 327 20.0 NA TRUE
8422 1958 Jan 21 0.0 332 199 NA TRUE
0477 anra . An A s A n an A [y e

» Return to the Prepare > Check Data > One Variable Summarise dialogue (You can use
the toolbar icon for recalling the last ten dialogues.
» Press Ok.
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Fig: 23 Summary of Filtered Data

YEET month
Min. 1558 1 :173¢
1st Qu.:1572 3 173&
Median :-158& 5 173&
Mean 1588 1 173&
Ard Qu.:-2000 8 173&
Man. 2013 10 173€6
1z 1736
4 -1&80
3 -1&80
[Cther) -4342
month_abbr doy_3E€
Jan -173¢ Mim. > 1
Mar 17386 lst Qu.: 33
May 11738 Median 124
Jul 1738 Mean 124
REng :173e 3rd Qu.:275
Qct :173e Max. t3EeE
Dec 1738
Epr z1&80
Jun z1&80

[Other) :4342

day
Min. - 1.
1st Qu.: &.
Median :lé.
Mean -15.
3rd Qu.:-23 .4
M. z31 .
rain
Him. 0
lst Qu.: 0
Hedizn : O.f
Hean 1
2rd Qu.: 0O
Max 115
Ni's=s =91

SRR s R = ]

.00
.00

.58
.00

date
Min. :1358-01-01
1st Qu.:1372-01-01
Median :1385-12Z-31
Mezn :1385-12-31
3rd Qu.:13%5%5-12-31
Max. $2013-12-31
tmax tmin
Min. :15.2 Min. - 1.5
1st Qu.:27.4 1st Qu.:15.1
Median :Z25.0 Median :17.2
Mean tEB.S Mean 1e.8
3rd Qu.:30.5 2rd Qu.:18.%
Mzx. 35.5 Max. 1255
N&'s t230 N&'=s s302

The results (Fig 23) include that there were only 230 missing days in tmax, from when

temperatures were measured. A few more were missing in tmin.

2.2 PRODUCING YEARLY SUMMARIES

The daily data are now ready to be summarized to produce the yearly means.

> Open the Prepare > Column: Reshape > Column Summaries dialogue (Fig 24)

Fig 24: Menu for Column Summaries

With the resulting dialog

Variable(s) to Summarise:

dodoma
tmax
tmin

[] Weights

Summarise By:
dodoma

year

Summaries...

Prop. and Percentages...

code generated by the dialog Column Statistics |

Prepare | Describe Model  Structured  Climatic  Procure Colurnn Statistics
Data Frame ﬁ ]N = E
Check Data » 1 @ Data Frame:
dodoma ~
Calculator...
date (0) | month_abbr | doy_36¢ Variables ~
Column: Calculate  »
1935-01-01 Jan 1 year

Column: Factor 4 1925-01-02 Jan 2 month Add

. day
Eol et * 11935-01-03 Jan 3 e
Column: Date ¥ 15835-01-04 Jan 4 month_abbr Dats
Column: Define » 15935-01-05 Jan 5 doy_366 ~ | | Options

Options
Data Reshape 4 Column Summaries... Store Resutts
Keys and Links 2 General Summaries... [ Original Level
Data Object » Stack... [] Print Results to Output
R Objects 4 Unstack...
1 11 Merge... Omit Migsing Values Missing Options
! 12 A d Data Fi
1 12 ppend Data Frames... —
Subset...

1 14 Ck Reset Close
1 15 Random Subset...
1 16 Transpose...

Help

Lan To Script

» Complete the dialogue (Fig. 24), i.e. Tmin and Tmax into the main receiver,

Year into the other receiver, and the option ticked to Omit Missing Values.

> Then press the Summaries button to move to the sub-dialogue (Fig. 25)
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» Complete the sub-dialogue as shown in Fig 25, i.e. with only two summaries
for the N Not Missing and the Mean. Then press Return and OK to produce
the summaries.

Fig 25: Summaries Sub-dialog With the Resulting Data
0

Summaries 5
year (f) | mean_tmax count_non_ = mean_tmin  count_non_
. i " 1 -_1958 29.0 365 16.1 365
Summaries  More Two-Variables Postion Model Cincular 2 1959 8.7 65 163 65
Common 3 1960 290 365 159 365
N Non Missing 1 N Total ] N Missing 4 1961 293 365 171 365
5 1962 29.0 365 16.1 365
] Mode 1 n_distinct 6 1963 285 363 16.0 331
7 1964 289 360 15.7 359
8 1965 288 363 16.0 354
All but {unordered) Factor 90 1966 291 365 16.6 364
- 10 1967 285 365 16.7 365
[ Minimm [ Madmum 1 1968 279 366 15.6 366
] Range 2 1969 297 365 17.0 365
131970 28.6 365 16.5 365
14 1971 285 365 16.3 365
Numeric 15 1972 28.8 366 16.6 366
[ Sum Mean [ Median 16 1973 295 362 16.6 334
17 1974 288 304 16.2 304
O sd [ Var 8 1975 29.1 365 16.8 365
19 1976 292 366 16.9 366
20 1977 28.7 364 171 364
Quartiles 21 1978 285 365 16.8 322
[ Lower Quartile [ Upper Quartile 2 1979 284 365 16.5 364
23 1980 289 366 17.0 366
24 1981 291 365 16.7 365
% 2RR 188 kTN :
< » dodoma | dodoma_by year s
Retum Help Showing 56 of 56 rows | Showing 5 of 5 columns

Fig. 25 The results are in a new sheet — or data frame in R terminology. There are just 56
rows, with one for each year. And they start in 1958. (Video: Indicate the number of years at
the bottom of the data frame.)

So, now the daily data are in the first data frame and the annual summaries are in a second
one.

That was easy. The Prepare stage has not taken too long.
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CHAPTER 3 — ANALYSING THE DATA

3.1 PRODUCING GRAPHS

> Use Describe > Specific > Line Plot, Fig. 26.

» Complete the dialogue as shown in Fig. 26 for the with mean_tmin as the y and year

as the x.
> Add the points, and the fitted line.

> Press OK.

Fig 26: The line plot menu

Describe | Model  Structured  Climatic  Procurement  Optioi
One Variable b . ﬁ . E .
Twe Variables »

Three Variables >
Specific 4 Frequency Tables...
General 4 Summary Tables...
Multivariate » Multiple Response...
Use Graph... Scatter Plot...
Combine Graphs... Line Plot...
Themes... Histogram...
View Graph... Boxplot...
Dot Plot...
0 NA Rug Plot...
g NA Bar Chart.
ar Chart...
0 NA
0 NA Curnulative Distribution...
] NA Parallel Coordinate Plot..,
0 A Meosaic Plot...

The resulting graph is shown in Fig. 26.

And the dialog

Line Plot
Data Frame:
dodoma_by_year ~ Single Variable
Variables
year
mean_tmax Add
count_non_missing_tmax
mean_tmin
count_non_missing_tmin Data
Options
X Variable:
——
Fact jonal):
Group:
Add Line of Best Fit With Standard Emor
[] Add Peaks ] Add Valleys
[] Save Graph

Comment: |code generated by the dialog Line Plot

Ok Reset Close Help | Lan

To Script

10
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Fig 26: The Graph for t-min And for t-max

G803 5343E3 036361 33030 930391 921593004303 94 31 SR8 M L0000 F0R0200R0001 Q0 21 2013
Yearl Year!

The result indicates that maximum temperatures have not increased so much.

3.2 SAVING THE DATA

Before using a different data set save these data, so you could resume later.
> Use the File > Save As dialog, Fig. 27. Choose the option Save Data As.

> Press on Browse in the dialogue, Fig. 27. Choose a suitable directory and name. Press OK

when you return to the Save Data dialogue.

Fig 27: Saving the Data set

R Relnstat 055
[File | Edit Prepare Describe Model Climatic Procurement  Optio Save Data As ‘

= o I e EHJ@E

b | count_non_ | mean_Tmin | court_not Save Data To: [C:/Users/User/Dowmems/R-lnstat/dodoma tutorial RDS ] Browse

365 16.1 365

Open From ODK.

en PRO
L o 365 16.3 365 9 3
meo atabases T Click Ok to confim the save

Import and Tidy NetCOF File... 365 171 365

T [ Comment: ICode generated by the dialog. Save Data As l
360 157 359

SRy » Save Data As... Ok Reset Close Help To Script

Export » Save Output Window As...
Print. Ctrl+P Save Log As...
Print Previe Save Script Window As...

Save... CtrlsS

Close Data File

365 165 365

The RDS extension is added, to signify it is saved as an R data file. This is a "silver lining", if done well,
the data only have to be organised once. Then the resulting file, with the two data frames, can be

opened in the future, and the analysis can be continued.

There are more analyses that can be explored with this data in R-Instat and we encourage you now to

try. The next part of the tutorial focuses on working with labelled data.

11
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CHAPTER 4 FEEDBACK AND REPORTING BUGS

R-Instat is still under active development with many improvements and new features planned for
future versions. We appreciate feedback you can have to help us improve R-Instat. There are several

ways you can provide your feedback:
1. Forgeneral feedback you can contact us via email at R-Instat (at) AfricanMathsInitiative.net

2. Ourissues page on our GitHub account can be used to report specific bugs or suggestions and

this is the most direct way to contact the development team. Note that our issues page is

publicly visible to anyone. It can be accessed here:

https://github.com/africanmathsinitiative/R-Instat/issues. Click the green New Issue button

on the right side to send your message.

When reporting a bug or problem, it's most helpful to us if you can be as specific as possible and

detail how to reproduce the bug, pasting the R code from the log file and attaching data if possible.

R-Instat Team, African Data Initiative.
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